Af10c65fe3b48f0a54e50116ef4e2d9e
2015/11/24 15:41:45 投稿
0

より正確な名前付け

before では refactoring という漠然とした名前の変数を使用していたが、someone_refactroing と名前を変えて誰のリファクタリングが分かるように名前付けをした sushi

Before

describe 'refactoring test' do
  let(:my_refactoring) { build_stubbed :refactoring, user: user }
  let(:refactoring) { build_stubbed :refactoring }

  # do something....
end

After

describe 'refactoring test' do
  let(:my_refactoring) { build_stubbed :refactoring, user: user }
  let(:someone_refactoring) { build_stubbed :refactoring, user: (build_stubbed :user) }

  # do something....
end

みんなのコメント

Nobody
fujimura
2015/11/25 11:23:34 投稿

someones_refactoring にして my と格を揃えるとより良いかと。

Af10c65fe3b48f0a54e50116ef4e2d9e
app2641
2015/11/25 12:03:00 投稿

なるほど、確かにそちらのほうが良さそうですね!
ありがとうございます sushi